about summary refs log tree commit diff
path: root/third_party/grpc/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-07T12·34+0200
committertazjin <mail@tazj.in>2021-04-11T22·13+0000
commit7deabb8c8d6f4c7e58e2b16548b8a1895795963b (patch)
treec7b55b5ec32d9c1e45ca3b4f33ef14d2cf82265f /third_party/grpc/default.nix
parent9073ac18c48f2bcefc736839d6faf76a462bf433 (diff)
chore(3p): Bump channels to 2021-04-09 r/2481
Fixes included:

* exposed gtest in the package set, required for protobuf
* pinned SBCL to version 2.0.8: The channel moved it to >2.1, and a
  bunch of warnings seemed to be killing our builds - we should
  investigate this later.
* removed kernel patches from //users/tazjin/frog: this machine is
  currently out of service anyways, not worth fixing while it's offline
* removed steam & lutris from frog (they're currently broken)
* removed Haskell overrides for hedgehog-classes & hgeometry-combinatorial
* use gRPC sources from upstream and inject Abseil via Nix instead
* fix for renamed grpc import in //third_party/nix
* use libfprint-tod from upstream nixpkgs in glittershark/yeren and
  delete glittershark/pkgs/fprintd entirely, since all of the patches used
  there are available and working from upstream now (and stopped working
  here after the bump)

Change-Id: Ia90e6f774f7b88bc9e60d28351b900ca43ee2695
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2901
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'third_party/grpc/default.nix')
-rw-r--r--third_party/grpc/default.nix11
1 files changed, 1 insertions, 10 deletions
diff --git a/third_party/grpc/default.nix b/third_party/grpc/default.nix
index 87ae5d7a32..f8fd1ac896 100644
--- a/third_party/grpc/default.nix
+++ b/third_party/grpc/default.nix
@@ -3,17 +3,8 @@
 (pkgs.grpc.override {
   protobuf = depot.third_party.protobuf;
   stdenv = pkgs.llvmPackages.libcxxStdenv;
+  abseil-cpp = depot.third_party.abseil_cpp;
 }).overrideAttrs(orig: rec {
-  version = "1.30.0";
-
-  src = pkgs.fetchFromGitHub {
-    owner = "grpc";
-    repo = "grpc";
-    rev = "v${version}";
-    sha256 = "01w5jdp318i7ncxbkfv75q0mf0rd3qwfr1ycdd3850nv6mprv7n0";
-    fetchSubmodules = true;
-  };
-
   cmakeFlags = orig.cmakeFlags ++ [
     "-DCMAKE_CXX_STANDARD=17"
     "-DCMAKE_CXX_STANDARD_REQUIRED=ON"