about summary refs log tree commit diff
path: root/third_party/gopkgs/golang.org
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-19T16·25+0000
committerVincent Ambo <tazjin@google.com>2019-12-19T16·25+0000
commit36fa320e554bcba2abbe48c55b1b4311a9ce8d46 (patch)
tree1698d5fe52495154b4a9692c330dfa61180e18c8 /third_party/gopkgs/golang.org
parent3fb29b1843b3e800365776d26b0320f1518b77ec (diff)
feat(third_party): Add Go packages for src-d/go-git r/206
This is going to be used in my git syncing tool for the cgit setup.
Diffstat (limited to 'third_party/gopkgs/golang.org')
-rw-r--r--third_party/gopkgs/golang.org/x/crypto/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/third_party/gopkgs/golang.org/x/crypto/default.nix b/third_party/gopkgs/golang.org/x/crypto/default.nix
new file mode 100644
index 0000000000..9610157d31
--- /dev/null
+++ b/third_party/gopkgs/golang.org/x/crypto/default.nix
@@ -0,0 +1,15 @@
+{ pkgs, ... }:
+
+pkgs.buildGo.external {
+  path = "golang.org/x/crypto";
+  src = builtins.fetchGit {
+    url = "https://go.googlesource.com/crypto";
+    rev = "e9b2fee46413994441b28dfca259d911d963dfed";
+  };
+
+  deps = with pkgs.third_party; [
+    # gopkgs."golang.org".x.text.secure.bidirule.gopkg
+    # gopkgs."golang.org".x.text.unicode.bidi.gopkg
+    # gopkgs."golang.org".x.text.unicode.norm.gopkg
+  ];
+}