about summary refs log tree commit diff
path: root/third_party/gopkgs/golang.org/x/net/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-13T12·12+0000
committerVincent Ambo <tazjin@google.com>2019-12-13T12·12+0000
commit9594203e07f51541b56ac08c752d5f30ec2d2de2 (patch)
tree541239e848f904230e211c540f604866e6e90373 /third_party/gopkgs/golang.org/x/net/default.nix
parent8b10c8d0f3c60b480c7d69dcfff2a9c974c56b89 (diff)
feat(third_party/gopkgs): Import external packages for Google Cloud r/123
These packages contain the Cloud SDK for Go. There is currently a
linker issue (presumably due to something in `buildGo.nix`) that means
that projects using them can not actually be built.
Diffstat (limited to 'third_party/gopkgs/golang.org/x/net/default.nix')
-rw-r--r--third_party/gopkgs/golang.org/x/net/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/third_party/gopkgs/golang.org/x/net/default.nix b/third_party/gopkgs/golang.org/x/net/default.nix
new file mode 100644
index 0000000000..571a2b1d36
--- /dev/null
+++ b/third_party/gopkgs/golang.org/x/net/default.nix
@@ -0,0 +1,15 @@
+{ pkgs, ... }:
+
+pkgs.buildGo.external {
+  path = "golang.org/x/net";
+  src = builtins.fetchGit {
+    url = "https://go.googlesource.com/net";
+    rev = "74dc4d7220e7acc4e100824340f3e66577424772";
+  };
+
+  deps = with pkgs.third_party; [
+    gopkgs."golang.org".x.text.secure.bidirule.gopkg
+    gopkgs."golang.org".x.text.unicode.bidi.gopkg
+    gopkgs."golang.org".x.text.unicode.norm.gopkg
+  ];
+}