about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-12-15T23·09-0500
committergrfn <grfn@gws.fyi>2021-12-16T14·17+0000
commitd85c6a1b56eae850a972d7c0708525a736d33d01 (patch)
treed8ab9097fb9da173928dbf04a840e35b11f1a4d7 /third_party/default.nix
parent01f4212ca184c9be40b84a3f9365c17796d6b6f3 (diff)
feat(ops/modules): Provide some modules to all nixoses r/3266
For modules that are gated behind a mkEnableOption, it's reasonable to
just provide them to all Depot-built nixos systems without requiring
people to explicitly import them. This defines a special module called
`default-imports.nix` which imports these modules (currently just
tvl-cache.nix and automatic-gc.nix, as I'm being rather conservative
adding things here to avoid breaking anyone's system), then provides
that module as one of the `modules` passed at the top-level
nixos/eval-config invocation.

Change-Id: I3be299ab10ae4c451ef11c514edb3c89318a2278
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4345
Tested-by: BuildkiteCI
Autosubmit: grfn <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 5a244ed220..e9e3c117ce 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -12,7 +12,7 @@
 #    other folders below //third_party, other than the ones mentioned
 #    above.
 
-{ pkgs, ... }:
+{ pkgs, depot, ... }:
 
 {
   # Expose a partially applied NixOS, expecting an attribute set with
@@ -33,7 +33,10 @@
   let
     eval = import "${pkgs.path}/nixos/lib/eval-config.nix" {
       inherit specialArgs system;
-      modules = [ configuration ];
+      modules = [
+        configuration
+        (import "${depot.path + "/ops/modules/default-imports.nix"}")
+      ];
     };
 
     # This is for `nixos-rebuild build-vm'.