about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-08-04T17·43+0100
committertazjin <mail@tazj.in>2020-08-06T00·15+0000
commitd42c3dd72f3294f2a5af9bd66858d36aedce32a8 (patch)
tree8e2ca7ae5c8f4fc0e1f00a6864c7ce2a1d1869e3 /third_party/default.nix
parent68b5306c562c30df5ede227b451eadbf92c5c311 (diff)
chore(3p): Bump nixpkgs channels r/1604
Bumps both nixos-unstable and nixos-20.03 to today's versions, as per
status.nixos.org

Contains minor fixes to things that broke because of the update:

* tazjin/frog: hardware.u2f is a deprecated setting
* glittershark/system: modSha256 in Go modules is now vendorSha256
* glittershark/owothia: removed version constraint on relude

Change-Id: Ib3e9612b1b06ed547b90e4f8b0ffe5ed7fe0a5c4
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1642
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 4bbcc6862c..3be8323209 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,11 +5,11 @@
 { ... }:
 
 let
-  # Tracking nixos-unstable as of 2020-06-10.
-  nixpkgsCommit = "467ce5a9f45aaf96110b41eb863a56866e1c2c3c";
+  # Tracking nixos-unstable as of 2020-08-04.
+  nixpkgsCommit = "840c782d507d60aaa49aa9e3f6d0b0e780912742";
   nixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs-channels/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "0qz7wgi61pdb335n18xm8rfwddckwv0vg8n7fii5abrrx47vnqcj";
+    sha256 = "14q3kvnmgz19pgwyq52gxx0cs90ddf24pnplmq33pdddbb6c51zn";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
@@ -21,11 +21,11 @@ let
     ];
   };
 
-  # Tracking nixos-20.03 as of 2020-05-22
-  stableCommit = "48723f48ab92381f0afd50143f38e45cf3080405";
+  # Tracking nixos-20.03 as of 2020-08-04.
+  stableCommit = "977000f149bd4ddb65bf1af09552898a0f305c72";
   stableNixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs-channels/archive/${stableCommit}.tar.gz";
-    sha256 = "0h3b3l867j3ybdgimfn76lw7w6yjhszd5x02pq5827l659ihcf53";
+    sha256 = "1ad3bviywxd64g4vwk4ppjkkajd3rfqjhnp6xcz3w0ih0sbn0rh5";
   };
   stableNixpkgs = import stableNixpkgsSrc {};