about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-03-03T22·03+0100
committerProfpatsch <mail@profpatsch.de>2021-04-01T11·27+0000
commitb89d4c1578aa7c9f43c840c2f0b805b016eb8fb5 (patch)
tree1c93f9fcf338c8a7c57445ddde41ca8668859c51 /third_party/default.nix
parent59a9955d753d8f9deb705d36922f6e8d77307f1d (diff)
feat(third_party): add dhall packages from easy-dhall-nix r/2383
About to do some dhalllll! \o/

Change-Id: Ie58c335d80f4a5abeb8296ece5a24377f07e6369
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2585
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix21
1 files changed, 20 insertions, 1 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index d64789c06f..c0a8b4df5d 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -38,14 +38,33 @@ in exposed.lib.fix(self: exposed // {
   # version of it.
   inherit nixpkgsCommit nixpkgsSrc stableNixpkgsSrc;
 
-  # Packages to be overridden
+  # Expose upstream attributes so they can be overridden in readTree nodes
   originals = {
     inherit (nixpkgs) gtest openldap go grpc notmuch rr;
     inherit (stableNixpkgs) git tdlib;
     ffmpeg = nixpkgs.ffmpeg-full;
     telega = stableNixpkgs.emacsPackages.telega;
+
   };
 
+  # binary releases of dhall tools, since the build in nixpkgs is broken most of the time.
+  # The binaries are also fully static builds, instead of the half-static crap that nixpkgs produces.
+  easy-dhall-nix =
+    import (builtins.fetchTarball {
+      url = "https://github.com/justinwoo/easy-dhall-nix/archive/eae7f64c4d6c70681e5a56c84198236930ba425e.tar.gz";
+      sha256 = "1y2x15v8a679vlpxazjpibfwajp6zph60f8wjcm4xflbvazk0dx7";
+    }) { pkgs = nixpkgs; };
+
+  dhall = self.easy-dhall-nix.dhall-simple;
+  dhall-bash = self.easy-dhall-nix.dhall-bash-simple;
+  dhall-docs = self.easy-dhall-nix.dhall-docs-simple;
+  dhall-json = self.easy-dhall-nix.dhall-json-simple;
+  dhall-lsp-server = self.easy-dhall-nix.dhall-lsp-simple;
+  dhall-nix = self.easy-dhall-nix.dhall-nix-simple;
+  # not yet in dhall-simple
+  # dhall-nixpkgs = self.easy-dhall-nix.dhall-nixpkgs-simple;
+  dhall-yaml = self.easy-dhall-nix.dhall-yaml-simple;
+
   # Use LLVM 11
   llvmPackages = nixpkgs.llvmPackages_11;
   clangStdenv = nixpkgs.llvmPackages_11.stdenv;