about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-30T16·06+0300
committertazjin <tazjin@tvl.su>2022-01-31T16·11+0000
commitaa122cbae78ce97d60c0c98ba14df753d97e40b1 (patch)
tree12b98d85c4b18fe870feb26de70db9ba61837bd7 /third_party/default.nix
parent2d10d60fac0fd00a71b65cfdcb9fba0477b2086c (diff)
style: format entire depot with nixpkgs-fmt r/3723
This CL can be used to compare the style of nixpkgs-fmt against other
formatters (nixpkgs, alejandra).

Change-Id: I87c6abff6bcb546b02ead15ad0405f81e01b6d9e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4397
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: cynthia <cynthia@tvl.fyi>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: eta <tvl@eta.st>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix55
1 files changed, 28 insertions, 27 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index e9e3c117ce..169727f4b9 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -24,32 +24,33 @@
   # be able to pass `specialArgs`. We depend on this because `depot`
   # needs to be partially evaluated in NixOS configuration before
   # module imports are resolved.
-  nixos = {
-    configuration,
-    specialArgs ? {},
-    system ? builtins.currentSystem,
-    ...
-  }:
-  let
-    eval = import "${pkgs.path}/nixos/lib/eval-config.nix" {
-      inherit specialArgs system;
-      modules = [
-        configuration
-        (import "${depot.path + "/ops/modules/default-imports.nix"}")
-      ];
-    };
+  nixos =
+    { configuration
+    , specialArgs ? { }
+    , system ? builtins.currentSystem
+    , ...
+    }:
+    let
+      eval = import "${pkgs.path}/nixos/lib/eval-config.nix" {
+        inherit specialArgs system;
+        modules = [
+          configuration
+          (import "${depot.path + "/ops/modules/default-imports.nix"}")
+        ];
+      };
 
-    # This is for `nixos-rebuild build-vm'.
-    vmConfig = (import "${pkgs.path}/nixos/lib/eval-config.nix" {
-      inherit specialArgs system;
-      modules = [
-        configuration
-        "${pkgs.path}/nixos/modules/virtualisation/qemu-vm.nix"
-      ];
-    }).config;
-  in {
-    inherit (eval) pkgs config options;
-    system = eval.config.system.build.toplevel;
-    vm = vmConfig.system.build.vm;
-  };
+      # This is for `nixos-rebuild build-vm'.
+      vmConfig = (import "${pkgs.path}/nixos/lib/eval-config.nix" {
+        inherit specialArgs system;
+        modules = [
+          configuration
+          "${pkgs.path}/nixos/modules/virtualisation/qemu-vm.nix"
+        ];
+      }).config;
+    in
+    {
+      inherit (eval) pkgs config options;
+      system = eval.config.system.build.toplevel;
+      vm = vmConfig.system.build.vm;
+    };
 }