about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-03-18T21·08+0100
committersterni <sternenseemann@systemli.org>2021-03-19T14·00+0000
commit90fdd7f23d6cc0d1374332d49218aef9a0d6a52f (patch)
tree8155b391ad41419b24912455d679289eff98306b /third_party/default.nix
parentc32e8424be3257a6ad3f913aa923989a5c0a40ba (diff)
chore(3p): bump NixOS channels to 2021-03-18 r/2284
Making this a monthly service apparently.

Necessary changes:

* 3p: expose emacs27 instead of emacs26 which got removed
  users/tazjin/{camden, frog}: switch from emacs26 to emacs27

* 3p/lieer: google_api_python_client got renamed to
  google-api-python-client

Change-Id: I1011665d10eebc99990addbef6a8a6b000b93896
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2605
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index c3c5ea11bb..834ae01e58 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,11 +5,11 @@
 { ... }:
 
 let
-  # Tracking nixos-unstable as of 2021-02-18.
-  nixpkgsCommit = "6b1057b452c55bb3b463f0d7055bc4ec3fd1f381";
+  # Tracking nixos-unstable as of 2021-03-18.
+  nixpkgsCommit = "1f77a4c8c74bbe896053994836790aa9bf6dc5ba";
   nixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "10qfg11g8m0q2k3ibcm0ivjq494gqynshm3smjl1rfn5ifjf5fz8";
+    sha256 = "1j62nmzz3w33dplzf1xz1pg1pfkxii7lwdqmsxmc71cs9cm3s7n1";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
@@ -21,11 +21,11 @@ let
     ];
   };
 
-  # Tracking nixos-20.09 as of 2021-02-17.
-  stableCommit = "5c53c720ff690ef82a9fe4849e7b70c104e1c82f";
+  # Tracking nixos-20.09 as of 2021-03-15.
+  stableCommit = "12d9950bf47e0ac20d4d04e189448ee075242117";
   stableNixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${stableCommit}.tar.gz";
-    sha256 = "0gjxfxbfc6maqg48k9ai476s6zkc94p0y3v9yjgwbiy7b38pqfys";
+    sha256 = "09wy33zbzxj33296ddrrb79630kxpj1c3kiv38zs4wrw24206c2v";
   };
   stableNixpkgs = import stableNixpkgsSrc {};