about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-12-25T10·13+0100
committertazjin <mail@tazj.in>2021-01-09T13·21+0000
commit88bf43878f243ca0276da4a21aa6a00a6a0dbc3c (patch)
treee946796ccccb079a5995a7eedbf46f41f383e11d /third_party/default.nix
parent68c4730365a2874ee26d3cc92fbeb073de460a4b (diff)
chore(3p): Bump NixOS channels to 2020-12-28 r/2065
Changes:

* ops/nixos/tvl-slapd: The NixOS module for OpenLDAP has removed the
  ability to configure OpenLDAP directly and now forces users to use
  some kind of weird Nix->OLC mapping that is mostly undocumented.

  This moves the config we need to the new format in a way that may or
  may not work and does the other arbitrary dance steps that someone
  decided to impose on us. Note that this now throws lots of warnings,
  but I can't be bothered to fix them.

* 3p: Random package removals accomodated

* users/glittershark: Pin grfn's kernel to 5.9, because the CK patch
  is not yet updated for 5.10

* users/glittershark: Update vendor hash for pg-dump-upsert, I suspect
  this changed because of something in the Go build machinery in
  nixpkgs. The deleteVendor flag also has no effect anymore and has been
  removed.

* users/glittershark: agda build is broken, commenting out development
  home-manager environment until it can be fixed

* third_party/haskell_overlay: updating random needs upper boundarles
  of a few dependencies relaxed (curse them)

* third_party/gerrit_plugins: for some cursed reason the fixed-output
  hash of the gerrit owners plugin fetchgit changed, updated.
  Same for the checks plugin.

Change-Id: Ica37995fe8039d3ba80eab643867f98795c56734
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2295
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 086e25ab85..6d70fa0723 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,11 +5,11 @@
 { ... }:
 
 let
-  # Tracking nixos-unstable as of 2020-11-21.
-  nixpkgsCommit = "a322b32e9d74fb476944ff6cfb55833dc69cfaaa";
+  # Tracking nixos-unstable as of 2020-12-28.
+  nixpkgsCommit = "2f47650c2f28d87f86ab807b8a339c684d91ec56";
   nixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
-    sha256 = "1r0mkiqxija75spnyksmh8x5j4smnrxv5f7768s81gsl570kls0l";
+    sha256 = "17akl75x28rzq97gaad32flswdsp150nfsg7h909kda721zql71a";
   };
   nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
@@ -21,11 +21,11 @@ let
     ];
   };
 
-  # Tracking nixos-20.09 as of 2020-11-21.
-  stableCommit = "58f9c4c7d3a42c912362ca68577162e38ea8edfb";
+  # Tracking nixos-20.09 as of 2020-12-28.
+  stableCommit = "0c81b9a4f170f734bd7e587a39e56470c59733e7";
   stableNixpkgsSrc = fetchTarball {
     url = "https://github.com/NixOS/nixpkgs/archive/${stableCommit}.tar.gz";
-    sha256 = "1517dy07jf4zhzknqbgm617lgjxsn7a6k1vgq61c67f6h55qs5ij";
+    sha256 = "1fl5ks6p78bamqanbk9xpy83jzzcdw2mdabrp59n33xv7jix1jzx";
   };
   stableNixpkgs = import stableNixpkgsSrc {};