about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-01-26T13·05+0300
committertazjin <mail@tazj.in>2021-01-26T13·25+0000
commit83465be599f2ed8d55dae0262156869fb78240a1 (patch)
treeea0bfcc664ef7facb648286d7c489e53e6524ed2 /third_party/default.nix
parentaa6e7f7c107a3222dc919abb54784625d106b5c8 (diff)
feat(3p/telega): Pin tdlib version used for telega r/2146
Recent channel updates have caused some issues for telega.el, mostly
because the version of tdlib (the C++ library for Telegram) and the
Emacs package are out of sync.

This overrides the version used in the Emacs package to a "known good"
commit. It would be useful to change the tdlib derivation in nixpkgs
to make this version mismatch a hard build error.

Change-Id: I9c994f783e1cc17e933432507cd13b65697efd4a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2445
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index dafc76f8bb..5c99b55d15 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -41,8 +41,9 @@ in exposed.lib.fix(self: exposed // {
   # Packages to be overridden
   originals = {
     inherit (nixpkgs) gtest openldap go grpc notmuch rr;
-    inherit (stableNixpkgs) git;
+    inherit (stableNixpkgs) git tdlib;
     ffmpeg = nixpkgs.ffmpeg-full;
+    telega = stableNixpkgs.emacsPackages.telega;
   };
 
   # Use LLVM 11
@@ -66,9 +67,6 @@ in exposed.lib.fix(self: exposed // {
   emacs27-nox = assert ((exposed.lib.versions.major nixpkgs.emacs.version) == "27");
     nixpkgs.emacs-nox;
 
-  # Provide telega.el from stable
-  stableTelega = stableNixpkgs.emacsPackages.telega;
-
   # The Go authors have released a version of Go (in alpha) that has a
   # type system. This makes it available, specifically for use with
   # //nix/buildTypedGo.