about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-01-11T08·55+0100
committerProfpatsch <mail@profpatsch.de>2021-01-11T19·44+0000
commit6843016aae40859ddb00a9721aa78c301c353f8d (patch)
treeefb41eba6f453f5fd996c90985bd97c2912127d5 /third_party/default.nix
parent923d90990ee829df71f45a26287be6c9c14bb47b (diff)
chore(third_party): move nixkpgs-exposed to subdir to fix OWNERS r/2075
The owners plugin should in theory be able to match on subdirs (at
least according to its documentation, but it doesn’t and nobody has
any idea how to debug it.

We already know that subdirectories work just fine, so let’s go the
path of least resistance because frankly, I couldn’t care any less.

The haskell overlay also moves to the subdir, this way both can be
changed in the same go by the same people.

Change-Id: I7d98f48afa649ad2c58e38e674e1c4df09039c1c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2347
Tested-by: BuildkiteCI
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 6d70fa0723..7638d98d65 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -29,7 +29,7 @@ let
   };
   stableNixpkgs = import stableNixpkgsSrc {};
 
-  exposed = import ./nixpkgs-exposed.nix { inherit nixpkgs stableNixpkgs; };
+  exposed = import ./nixpkgs-exposed/exposed { inherit nixpkgs stableNixpkgs; };
 
 in exposed.lib.fix(self: exposed // {
   callPackage = nixpkgs.lib.callPackageWith self;