about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-01-01T15·49+0100
committerVincent Ambo <tazjin@google.com>2020-01-01T15·53+0100
commit27f5eb5f67263c98e927097f8c4523a79ac6cd1f (patch)
tree99d90500401c6fd59c98f88b403b4bff2b8b89ec /third_party/default.nix
parent59aeebd495df96c694924f8fef3c9aa5e82942ca (diff)
chore(third_party): Bump packages to latest nixpkgs-unstable r/324
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix14
1 files changed, 6 insertions, 8 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index d96ce0022c..808a399641 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -5,14 +5,12 @@
 
 { pkgs, ... }:
 let
-  # The pinned commit here is identical to the public nixery.dev
-  # version, since popularity data has been generated for that.
-  stableCommit = "3140fa89c51233397f496f49014f6b23216667c2";
-  stableSrc = fetchTarball {
-    url = "https://github.com/NixOS/nixpkgs-channels/archive/${stableCommit}.tar.gz";
-    sha256 = "18p0d5lnfvzsyfah02mf6bi249990pfwnylwhqdh8qi70ncrk3f8";
+  commit = "62ef779f2a5050549772722665bedf52f01268d2";
+  nixpkgsSrc = fetchTarball {
+    url = "https://github.com/NixOS/nixpkgs-channels/archive/${commit}.tar.gz";
+    sha256 = "1k97l4kr2vchvjd5j11hdwlsx1q01fmrhbs1v8b5v5iz35y0fv7s";
   };
-  nixpkgs = import stableSrc {
+  nixpkgs = import nixpkgsSrc {
     config.allowUnfree = true;
     config.allowBroken = true;
   };
@@ -98,7 +96,7 @@ in exposed // {
 
   # Provide the source code of nixpkgs, but do not provide an imported
   # version of it.
-  nixpkgsSrc = stableSrc;
+  inherit nixpkgsSrc;
 
   # Packages to be overridden
   originals = {