about summary refs log tree commit diff
path: root/tests/remote-builds.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-09-05T09·49+0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-09-05T09·49+0200
commitf8df935102325d1b33bbcc7d904dd573bced48d5 (patch)
tree71441e11cafa5750f8267bf37e236ed381b2c746 /tests/remote-builds.nix
parente74113a305edbbf1de6acc2560fbfded56299ed4 (diff)
tests/remote-builds.nix: Time out faster
Diffstat (limited to 'tests/remote-builds.nix')
-rw-r--r--tests/remote-builds.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tests/remote-builds.nix b/tests/remote-builds.nix
index 81b81b87c1..5e2688d1ad 100644
--- a/tests/remote-builds.nix
+++ b/tests/remote-builds.nix
@@ -60,6 +60,7 @@ in
           virtualisation.pathsInNixDB = [ config.system.build.extraUtils ];
           nix.package = nix;
           nix.binaryCaches = [ ];
+          programs.ssh.extraConfig = "ConnectTimeout 30";
         };
     };
 
@@ -69,14 +70,14 @@ in
 
       # Create an SSH key on the client.
       my $key = `${pkgs.openssh}/bin/ssh-keygen -t dsa -f key -N ""`;
-      $client->succeed("mkdir -m 700 /root/.ssh");
+      $client->succeed("mkdir -p -m 700 /root/.ssh");
       $client->copyFileFromHost("key", "/root/.ssh/id_dsa");
       $client->succeed("chmod 600 /root/.ssh/id_dsa");
 
       # Install the SSH key on the slaves.
       $client->waitForUnit("network.target");
       foreach my $slave ($slave1, $slave2) {
-          $slave->succeed("mkdir -m 700 /root/.ssh");
+          $slave->succeed("mkdir -p -m 700 /root/.ssh");
           $slave->copyFileFromHost("key.pub", "/root/.ssh/authorized_keys");
           $slave->waitForUnit("sshd");
           $client->succeed("ssh -o StrictHostKeyChecking=no " . $slave->name() . " 'echo hello world'");