about summary refs log tree commit diff
path: root/tests/lang/parse-fail-undef-var-2.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-07-24T16·35+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-07-24T16·35+0000
commitf4c5531d928caadee75d66bba40994f55f839be7 (patch)
tree04ed6655b0cf1043761b6d3978ff35b3794a6c42 /tests/lang/parse-fail-undef-var-2.nix
parent88acffa20ac45fd13b65a1d9143e0400ae0bde47 (diff)
* New language feature: domain checks, which check whether a function
  argument has a valid value, i.e., is in a certain domain.  E.g.,

    { foo : [true false]
    , bar : ["a" "b" "c"]
    }: ...

  This previously could be done using assertions, but domain checks
  will allow the buildfarm to automatically extract the configuration
  space from functions.

Diffstat (limited to 'tests/lang/parse-fail-undef-var-2.nix')
-rw-r--r--tests/lang/parse-fail-undef-var-2.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/lang/parse-fail-undef-var-2.nix b/tests/lang/parse-fail-undef-var-2.nix
new file mode 100644
index 0000000000..c10a52b1ea
--- /dev/null
+++ b/tests/lang/parse-fail-undef-var-2.nix
@@ -0,0 +1,7 @@
+let {
+
+  f = {x, y : ["baz" "bar" z "bat"]}: x + y;
+
+  body = f {x = "foo"; y = "bar";};
+
+}