about summary refs log tree commit diff
path: root/tests/lang/eval-okay-context.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-01-04T14·22+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-01-04T14·22+0000
commit7d0f6aed59b11ef1037e7b0ee4dae1c7288ebb45 (patch)
tree7b158d1eafd04f0d08426a9919beb635c48124d6 /tests/lang/eval-okay-context.nix
parent895c9538173a1c1d7e5f6c82e5b7a58b7d904683 (diff)
* New primop `unsafeDiscardStringContext' to get rid of string
  contexts.  Needed to prevent unnecessary dependencies when building
  the NixOS manual.

Diffstat (limited to 'tests/lang/eval-okay-context.nix')
-rw-r--r--tests/lang/eval-okay-context.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-context.nix b/tests/lang/eval-okay-context.nix
new file mode 100644
index 0000000000..b3f1748975
--- /dev/null
+++ b/tests/lang/eval-okay-context.nix
@@ -0,0 +1,6 @@
+let s = "foo ${builtins.substring 33 100 (baseNameOf ./eval-okay-context.nix)} bar";
+in
+  if s == "foo eval-okay-context.nix bar"
+  then abort "context not discarded"
+  else builtins.unsafeDiscardStringContext s
+