about summary refs log tree commit diff
path: root/tests/gc-concurrent.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
commit51e7e32c3bf7c2fb5045b0655c2edc1fbf347455 (patch)
tree21337c26d0106fa92b5f82854f623640b24dc34e /tests/gc-concurrent.nix
parent2d5114452d8a8f73c858f9beb6bfaafe35e7bf9a (diff)
* Refactoring: renamed *.nix.in to *.nix.
Diffstat (limited to 'tests/gc-concurrent.nix')
-rw-r--r--tests/gc-concurrent.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/gc-concurrent.nix b/tests/gc-concurrent.nix
new file mode 100644
index 0000000000..c0595cc471
--- /dev/null
+++ b/tests/gc-concurrent.nix
@@ -0,0 +1,27 @@
+with import ./config.nix;
+
+rec {
+
+  input1 = mkDerivation {
+    name = "dependencies-input-1";
+    builder = ./dependencies.builder1.sh;
+  };
+
+  input2 = mkDerivation {
+    name = "dependencies-input-2";
+    builder = ./dependencies.builder2.sh;
+  };
+
+  test1 = mkDerivation {
+    name = "gc-concurrent";
+    builder = ./gc-concurrent.builder.sh;
+    inherit input1 input2;
+  };
+
+  test2 = mkDerivation {
+    name = "gc-concurrent2";
+    builder = ./gc-concurrent2.builder.sh;
+    inherit input1 input2;
+  };
+  
+}