about summary refs log tree commit diff
path: root/tests.nix
diff options
context:
space:
mode:
authorMichael Fellinger <github@manveru.dev>2019-09-16T10·27+0200
committerVincent Ambo <github@tazj.in>2019-09-17T14·29+0100
commit7b1e389c664bca731be8ba66730be946a904d84c (patch)
tree9fa17f4145999177b9a6a0c5d761a74f91583e9f /tests.nix
parentafd2fd5058d14c99ca60e9be28ee778f5df1958d (diff)
Add path type
Diffstat (limited to 'tests.nix')
-rw-r--r--tests.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests.nix b/tests.nix
index 344f2c1f59..f2380a7709 100644
--- a/tests.nix
+++ b/tests.nix
@@ -12,6 +12,7 @@ deepSeq rec {
     (float 13.37)
     (string "Hello!")
     (function (x: x * 2))
+    (path /nix)
   ];
 
   # Test that polymorphic types work as intended
@@ -76,7 +77,7 @@ deepSeq rec {
 
   # Test that all types are types.
   testTypes = map type [
-    any bool drv float int string
+    any bool drv float int string path
 
     (attrs int)
     (either int string)