about summary refs log tree commit diff
path: root/system/modules/xserver.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-28T03·32-0400
committerGriffin Smith <root@gws.fyi>2020-03-28T15·47-0400
commit28ccec970435f9acfdecfae95848947c8b751e09 (patch)
tree4a55bdaab006c46cd5ad86d407d7d80fab8ed57f /system/modules/xserver.nix
Initial commit
It begins...
Diffstat (limited to 'system/modules/xserver.nix')
-rw-r--r--system/modules/xserver.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/system/modules/xserver.nix b/system/modules/xserver.nix
new file mode 100644
index 0000000000..52f04e2e6a
--- /dev/null
+++ b/system/modules/xserver.nix
@@ -0,0 +1,19 @@
+{ config, pkgs, ... }:
+{
+  # Enable the X11 windowing system.
+  services.xserver = {
+    enable = true;
+    layout = "us";
+    xkbOptions = "caps:swapescape";
+
+    libinput.enable = true;
+
+    windowManager.i3 = {
+      enable = true;
+      extraPackages = with pkgs; [
+        i3status
+        i3lock
+      ];
+    };
+  };
+}