about summary refs log tree commit diff
path: root/system/modules/sound.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-28T03·32-0400
committerGriffin Smith <root@gws.fyi>2020-03-28T15·47-0400
commit28ccec970435f9acfdecfae95848947c8b751e09 (patch)
tree4a55bdaab006c46cd5ad86d407d7d80fab8ed57f /system/modules/sound.nix
Initial commit
It begins...
Diffstat (limited to 'system/modules/sound.nix')
-rw-r--r--system/modules/sound.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/modules/sound.nix b/system/modules/sound.nix
new file mode 100644
index 0000000000..0d5ce3e318
--- /dev/null
+++ b/system/modules/sound.nix
@@ -0,0 +1,14 @@
+{ config, lib, pkgs, ... }:
+{
+  # Enable sound.
+  sound.enable = true;
+  hardware.pulseaudio.enable = true;
+  nixpkgs.config.pulseaudio = true;
+
+  environment.systemPackages = with pkgs; [
+    pulseaudio-ctl
+    paprefs
+    pasystray
+    pavucontrol
+  ];
+}