about summary refs log tree commit diff
path: root/system/modules/common.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-29T16·49-0400
committerGriffin Smith <root@gws.fyi>2020-03-29T16·49-0400
commit4a049b08b1afd62979d939daef733ed42b0964e2 (patch)
tree0101e8bc688e9d73f6f39afb61ce24f342328939 /system/modules/common.nix
parenta303e5c14d8ca768cba72fb1052d614508228415 (diff)
machine config for chupacabra
Diffstat (limited to 'system/modules/common.nix')
-rw-r--r--system/modules/common.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/system/modules/common.nix b/system/modules/common.nix
index 27f4a73f09..008863bdbf 100644
--- a/system/modules/common.nix
+++ b/system/modules/common.nix
@@ -6,12 +6,12 @@
       ./xserver.nix
       ./emacs.nix
       ./sound.nix
+      ./urbint.nix
     ];
 
   boot.loader.systemd-boot.enable = true;
   boot.loader.efi.canTouchEfiVariables = true;
 
-  networking.hostName = "bumblebee";
   networking.useDHCP = false;
   networking.networkmanager.enable = true;
 
@@ -65,9 +65,10 @@
     isNormalUser = true;
     initialPassword = "password";
     extraGroups = [
-      "wheel"  # Enable ‘sudo’ for the user.
+      "wheel"
       "networkmanager"
       "audio"
+      "docker"
     ];
     shell = pkgs.zsh;
   };
@@ -90,7 +91,7 @@
 
   powerManagement = {
     enable = true;
-    cpuFreqGovernor = "powersave";
+    cpuFreqGovernor = lib.mkDefault "powersave";
     powertop.enable = true;
   };
   # Hibernate on low battery