about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-01-24T09·53+0100
committerEelco Dolstra <edolstra@gmail.com>2017-01-24T09·53+0100
commit1102c77919765b22824ee481afd3bbd618ddb457 (patch)
treee41b88cb5e2cf6322653afcbd7a558de018bfe76 /shell.nix
parent8af062f372ae5db6a90700641f15d98505b4a839 (diff)
shell.nix: Add a flag for using clang
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index dd44841055..4c1608230c 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,6 +1,8 @@
+{ useClang ? false }:
+
 with import <nixpkgs> {};
 
-stdenv.mkDerivation {
+(if useClang then clangStdenv else stdenv).mkDerivation {
   name = "nix";
 
   buildInputs =