about summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@gmail.com>2018-03-09T13·14+0100
committerVincent Ambo <github@tazj.in>2018-03-09T13·51+0100
commit850fdcf3e0270db885f661ae59225db92143c3f2 (patch)
tree81e799f4b728095cfa6610009b4fdad0025a1d48 /release.nix
parenta1d9d8b199a3c9402c34ae1a12f85495d3c1cfd2 (diff)
feat(build): Pin nixpkgs used for release build
Pin the nixpkgs-commit used for building the Kontemplate release to a
specific commit.

Kontemplate builds should now be fully repeatable (and most likely
reproducible!) on any machine running Nix.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/release.nix b/release.nix
index fc047f26ac..fb80a0e420 100644
--- a/release.nix
+++ b/release.nix
@@ -10,13 +10,13 @@
 # This file is the Nix derivation used to build release binaries for
 # several different architectures and operating systems.
 
-{ pkgs ? import <nixpkgs> {} }:
-
-with pkgs; let buildGo110Package =
-  callPackage <nixpkgs/pkgs/development/go-modules/generic> {
-  go = go_1_10;
-};
-in buildGo110Package rec {
+let pkgs = import ((import <nixpkgs> {}).fetchFromGitHub {
+  owner  = "NixOS";
+  repo   = "nixpkgs";
+  rev    = "1bc5bf4beb759e563ffc7a8a3067f10a00b45a7d";
+  sha256 = "00gd96p7yz3rgpjjkizp397y2syfc272yvwxqixbjd1qdshbizmj";
+}) {};
+in with pkgs; buildGoPackage rec {
   name = "kontemplate-${version}";
   version = "master";
   src = ./.;