about summary refs log tree commit diff
path: root/read-tree.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
committerVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
commitc1c379848a19a31de8febb1385c7b9e4d2a474a3 (patch)
treef019521edfb4590b6c59d84e77c422a21671ca89 /read-tree.nix
parent4d852e2ef73a0901a3426ae5ab93232b6a0a8ed2 (diff)
chore(nix): Move files around to conform to new read-tree layout
Broadly speaking, the following things are included:

* there is now a uniform `args` struct that is passed to all
  derivations, package headers have been changed appropriately
* overrides are now loaded from a separate `override` folder just
  using read-tree.nix
* third-party packages have moved into the `third_party` attribute set
Diffstat (limited to 'read-tree.nix')
-rw-r--r--read-tree.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/read-tree.nix b/read-tree.nix
index 00a2e738bd..d883d12c81 100644
--- a/read-tree.nix
+++ b/read-tree.nix
@@ -1,4 +1,4 @@
-path: self: super:
+path: { pkgs, ... } @ args:
 
 let
   inherit (builtins)
@@ -15,8 +15,6 @@ let
     toPath
     toString;
 
-  args = { pkgs = self; };
-
   zipAttrs = names: values:
     if (names == []) || (values == [])
     then []