about summary refs log tree commit diff
path: root/overrides/lispPackages/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
committerVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
commitc1c379848a19a31de8febb1385c7b9e4d2a474a3 (patch)
treef019521edfb4590b6c59d84e77c422a21671ca89 /overrides/lispPackages/default.nix
parent4d852e2ef73a0901a3426ae5ab93232b6a0a8ed2 (diff)
chore(nix): Move files around to conform to new read-tree layout
Broadly speaking, the following things are included:

* there is now a uniform `args` struct that is passed to all
  derivations, package headers have been changed appropriately
* overrides are now loaded from a separate `override` folder just
  using read-tree.nix
* third-party packages have moved into the `third_party` attribute set
Diffstat (limited to 'overrides/lispPackages/default.nix')
-rw-r--r--overrides/lispPackages/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/overrides/lispPackages/default.nix b/overrides/lispPackages/default.nix
new file mode 100644
index 0000000000..da8f3c893a
--- /dev/null
+++ b/overrides/lispPackages/default.nix
@@ -0,0 +1,8 @@
+# One of Gemma's dependencies is missing in nixpkgs' Quicklisp
+# package set, it is overlaid locally here.
+{ pkgs, upstream, ... }:
+
+import ./quicklisp.nix {
+  inherit (pkgs) lib;
+  inherit (upstream) lispPackages;
+}