about summary refs log tree commit diff
path: root/ops/pipelines/depot.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-04-12T15·46+0200
committersterni <sternenseemann@systemli.org>2021-04-12T15·50+0000
commit0e6ac814c6fdaef02c4d270acab563a4de5acf40 (patch)
treebe523cfa8ec2fba8295f965c668f5b2239221a72 /ops/pipelines/depot.nix
parent0faba1a268f5bad1d14931a501fd482fe3c2319a (diff)
feat(ops/pipelines): pass --show-trace to nix-build r/2492
--show-trace should make it easier to debug tricky evaluation errors
without running nix-build -A ops.pipelines.depot locally again.

Change-Id: Ice540562c3b389fc2a49ec1fc0adacb17db2a528
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2947
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'ops/pipelines/depot.nix')
-rw-r--r--ops/pipelines/depot.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/ops/pipelines/depot.nix b/ops/pipelines/depot.nix
index 91fb6269d6..6415747e68 100644
--- a/ops/pipelines/depot.nix
+++ b/ops/pipelines/depot.nix
@@ -33,7 +33,7 @@ let
   # regardless, but this data is not accessible.
   mkStep = target: {
     command = ''
-      nix-build -E '${mkBuildExpr target}' || (buildkite-agent meta-data set "failure" "1"; exit 1)
+      nix-build -E '${mkBuildExpr target}' --show-trace || (buildkite-agent meta-data set "failure" "1"; exit 1)
     '';
     label = ":nix: ${mkLabel target}";
   };