about summary refs log tree commit diff
path: root/ops/nixos/www/wigglydonke.rs.nix
diff options
context:
space:
mode:
authorLuke Granger-Brown <git@lukegb.com>2021-04-02T12·18+0000
committerlukegb <lukegb@tvl.fyi>2021-04-02T18·00+0000
commitb35e358eb5841b62caa8408ce2dbee105bf8d9c8 (patch)
treeb8d00a42560ee0567bb663c8fd65b5dd7d796e83 /ops/nixos/www/wigglydonke.rs.nix
parent999f98436cf854d360269368f61a498e506167a4 (diff)
refactor(ops/nixos): migrate to depot module arg r/2407
Previously the depot argument was provided as config.depot, but the "new
way" of doing things (which is more like the args list provided in the
rest of the depot) is to provide this as the "depot" NixOS module
argument instead.

Change-Id: Ib48b1c7c1bdff9c1eb0618c6cbacc22b651f5f98
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2763
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'ops/nixos/www/wigglydonke.rs.nix')
-rw-r--r--ops/nixos/www/wigglydonke.rs.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/ops/nixos/www/wigglydonke.rs.nix b/ops/nixos/www/wigglydonke.rs.nix
index 0774eaea7c..0bc67898c6 100644
--- a/ops/nixos/www/wigglydonke.rs.nix
+++ b/ops/nixos/www/wigglydonke.rs.nix
@@ -1,4 +1,4 @@
-{ config, lib, pkgs, ... }:
+{ depot, lib, pkgs, ... }:
 
 {
   imports = [
@@ -9,7 +9,7 @@
     services.nginx.virtualHosts."wigglydonke.rs" = {
       enableACME = true;
       forceSSL = true;
-      root = "${config.depot.depotPath}/users/glittershark/wigglydonke.rs";
+      root = "${depot.depotPath}/users/glittershark/wigglydonke.rs";
     };
   };
 }