about summary refs log tree commit diff
path: root/ops/nixos/tvl-sso/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-11T20·50+0200
committertazjin <mail@tazj.in>2021-04-11T22·18+0000
commit90281c4eac4cd25045ed80c5f8f27c74898a02b3 (patch)
tree804425642af16b9e299d469ad6e21c6a23a400e9 /ops/nixos/tvl-sso/default.nix
parent7deabb8c8d6f4c7e58e2b16548b8a1895795963b (diff)
refactor(ops): Split //ops/nixos into different locations r/2482
Splits //ops/nixos into:

* //ops/nixos.nix - utility functions for building systems
* //ops/machines - shared machine definitions (read by readTree)
* //ops/modules - shared NixOS modules (skipped by readTree)

This simplifies working with the configuration fixpoint in whitby, and
is overall a bit more in line with how NixOS systems in user folders
currently work.

Change-Id: I1322ec5cc76c0207c099c05d44828a3df0b3ffc1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2931
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'ops/nixos/tvl-sso/default.nix')
-rw-r--r--ops/nixos/tvl-sso/default.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/ops/nixos/tvl-sso/default.nix b/ops/nixos/tvl-sso/default.nix
deleted file mode 100644
index 8e33c708b7..0000000000
--- a/ops/nixos/tvl-sso/default.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-# Configures an Apereo CAS instance for TVL SSO
-{ depot, ... }:
-
-let
-  inherit (depot.third_party) apereo-cas;
-in {
-  config = {
-    environment.systemPackages = [ apereo-cas ];
-    systemd.services.apereo-cas = {
-      description = "Apereo CAS Single Sign On server";
-      wantedBy = [ "multi-user.target" ];
-      after = [ "network.target" ];
-      serviceConfig = {
-        User = "apereo-cas";
-        Group = "apereo-cas";
-        ExecStart = "${apereo-cas}/bin/cas";
-        EnvironmentFile = "/etc/cas/secrets";
-        Restart = "always";
-      };
-    };
-    users.users.apereo-cas = {};
-    users.groups.apereo-cas = {};
-  };
-}