about summary refs log tree commit diff
path: root/ops/nixos/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-11-22T19·35-0500
committerglittershark <grfn@gws.fyi>2020-11-22T21·59+0000
commit9f4d37e5dfb41409e5a7e9bac43db93012d77f9f (patch)
tree36a39baf7b69bd2e83ab32038f10b0e5e5870b59 /ops/nixos/default.nix
parent58efa6df5bbecd4b0a2e0081a092b0f0f2425113 (diff)
feat(ops/nixos): Give all nixoses a config.depot r/1905
Add the depot.nix module and a depot config option to all nixos system
derivations that're build through the `bin/rebuild-system` machinery.
I can't imagine a scenario where we wouldn't want this level of
integration.

Change-Id: Ieeb98db2eee23919256adb4654bc45d540e055ec
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2128
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'ops/nixos/default.nix')
-rw-r--r--ops/nixos/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/ops/nixos/default.nix b/ops/nixos/default.nix
index 5bd32e4068..312d762f24 100644
--- a/ops/nixos/default.nix
+++ b/ops/nixos/default.nix
@@ -20,7 +20,13 @@ rec {
   allSystems = import ./all-systems.nix args;
 
   nixosFor = configuration: depot.third_party.nixos {
-    inherit configuration;
+    configuration = {
+      inherit depot;
+      imports = [
+        configuration
+        "${depot.depotPath}/ops/nixos/depot.nix"
+      ];
+    };
   };
 
   findSystem = hostname: