about summary refs log tree commit diff
path: root/ops/nixos/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T11·40+0200
committertazjin <mail@tazj.in>2021-04-10T12·09+0000
commit9c5b5600ea3e8916af5715185ef57e57f36cf82b (patch)
tree0342084d593bb5a672bc3764655c517ce3d007fc /ops/nixos/default.nix
parentd62fab4168129180e964a02a5a72c91623d1b962 (diff)
refactor(ops): Consistent use of depot.third_party vs. pkgs r/2464
In preparation for the solution of b/108, we need to consistently use
`depot.third_party` for packages that are only packed in the TVL depot
and `pkgs` for things that come from nixpkgs.

This commit cleans up a huge chunk of these uses in //ops

Change-Id: I00faeb969eaa70760a26256274925b07998c2351
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2915
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/nixos/default.nix')
-rw-r--r--ops/nixos/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/ops/nixos/default.nix b/ops/nixos/default.nix
index e6cb1a760a..fc3508b529 100644
--- a/ops/nixos/default.nix
+++ b/ops/nixos/default.nix
@@ -6,13 +6,12 @@
 #
 # TODO(tazjin): Find a more elegant solution for the whole module
 # situation.
-{ lib, pkgs, depot, ... }@args:
+{ depot, lib, pkgs, ... }@args:
 
 let
   inherit (lib) findFirst isAttrs;
-in
-
-rec {
+  nixos = import "${depot.third_party.nixpkgsSrc}/nixos";
+in rec {
   whitby = import ./whitby/default.nix args;
 
   # System installation
@@ -26,7 +25,7 @@ rec {
     };
   };
 
-  nixosFor = configuration: (depot.third_party.nixos {
+  nixosFor = configuration: (nixos {
     configuration = { ... }: {
       imports = [
         baseModule