about summary refs log tree commit diff
path: root/ops/kontemplate/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T11·40+0200
committertazjin <mail@tazj.in>2021-04-10T12·09+0000
commit9c5b5600ea3e8916af5715185ef57e57f36cf82b (patch)
tree0342084d593bb5a672bc3764655c517ce3d007fc /ops/kontemplate/default.nix
parentd62fab4168129180e964a02a5a72c91623d1b962 (diff)
refactor(ops): Consistent use of depot.third_party vs. pkgs r/2464
In preparation for the solution of b/108, we need to consistently use
`depot.third_party` for packages that are only packed in the TVL depot
and `pkgs` for things that come from nixpkgs.

This commit cleans up a huge chunk of these uses in //ops

Change-Id: I00faeb969eaa70760a26256274925b07998c2351
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2915
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/kontemplate/default.nix')
-rw-r--r--ops/kontemplate/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/ops/kontemplate/default.nix b/ops/kontemplate/default.nix
index eb12906877..1190869c3f 100644
--- a/ops/kontemplate/default.nix
+++ b/ops/kontemplate/default.nix
@@ -1,4 +1,4 @@
-# Copyright (C) 2016-2019  Vincent Ambo <mail@tazj.in>
+# Copyright (C) 2016-2021  Vincent Ambo <mail@tazj.in>
 #
 # This file is part of Kontemplate.
 #
@@ -10,15 +10,15 @@
 # This file is the Nix derivation used to install Kontemplate on
 # Nix-based systems.
 
-{ depot, ... }:
+{ lib, pkgs, ... }:
 
-with depot.third_party; buildGoPackage rec {
+pkgs.buildGoPackage rec {
   name = "kontemplate-${version}";
   version = "canon";
   src = ./.;
   goPackagePath = "github.com/tazjin/kontemplate";
   goDeps = ./deps.nix;
-  buildInputs = [ parallel ];
+  buildInputs = [ pkgs.parallel ];
 
   # Enable checks and configure check-phase to include vet:
   doCheck = true;