about summary refs log tree commit diff
path: root/ops/journaldriver/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-02-18T08·36+0300
committerclbot <clbot@tvl.fyi>2022-02-18T11·52+0000
commitede837b6873a4f475b66bb6ee44e7190cd404012 (patch)
tree035cd699537de9e1dbf1eedf888f006e21bb373e /ops/journaldriver/Cargo.toml
parent4ce2b49cd9e14f862f16326b925aadcc28b9fdb6 (diff)
refactor(journaldriver): Use anyhow instead of failure r/3852
Apparently failure is not hip anymore, and crate updates are forcing
the use of anyhow now. Whatever.

The functionality basically stays the same, maybe error messages will
look a little bit different now.

Change-Id: I173d644688785339c16161ddeec47a534123710f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5307
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'ops/journaldriver/Cargo.toml')
-rw-r--r--ops/journaldriver/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/ops/journaldriver/Cargo.toml b/ops/journaldriver/Cargo.toml
index 248b22807f..2c560d1406 100644
--- a/ops/journaldriver/Cargo.toml
+++ b/ops/journaldriver/Cargo.toml
@@ -5,9 +5,9 @@ authors = ["Vincent Ambo <mail@tazj.in>"]
 license = "GPL-3.0-or-later"
 
 [dependencies]
+anyhow = "1.0"
 chrono = { version = "0.4", features = [ "serde" ]}
 env_logger = "0.5"
-failure = "0.1"
 lazy_static = "1.0"
 log = "0.4"
 medallion = "2.2"