about summary refs log tree commit diff
path: root/ops/journaldriver/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-02-18T09·49+0300
committerclbot <clbot@tvl.fyi>2022-02-18T11·52+0000
commit71d6a02ca19857a06bc789f09c885e5cd77f7212 (patch)
treea64cf3e1e38da78b8c6ce0dda2483958545af016 /ops/journaldriver/Cargo.toml
parentaf512558e695605fdfc1b3ede407a6067e355e30 (diff)
refactor(journaldriver): Use time crate directly instead of chrono r/3856
With this change, we still depend on chrono (through medallion), but
but I'm going to try and fix that upstream as well.

Change-Id: Iefd3d8578ea8870961107f3222dea7f936c2dd9a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5311
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/journaldriver/Cargo.toml')
-rw-r--r--ops/journaldriver/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/ops/journaldriver/Cargo.toml b/ops/journaldriver/Cargo.toml
index 8cd2117726..51efc62bd3 100644
--- a/ops/journaldriver/Cargo.toml
+++ b/ops/journaldriver/Cargo.toml
@@ -7,7 +7,6 @@ edition = "2021"
 
 [dependencies]
 anyhow = "1.0"
-chrono = { version = "0.4", features = [ "serde" ]}
 env_logger = "0.5"
 lazy_static = "1.0"
 log = "0.4"
@@ -16,6 +15,7 @@ serde = "1.0"
 serde_derive = "1.0"
 serde_json = "1.0"
 systemd = "0.3"
+time = { version = "0.3", features = [ "serde-well-known", "macros" ]}
 ureq = { version = "0.6.2", features = [ "json" ]}
 
 [build-dependencies]