about summary refs log tree commit diff
path: root/ops/journaldriver/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-02-19T15·23+0300
committertazjin <tazjin@tvl.su>2022-02-20T15·46+0000
commit2cff0712b3a3c08ef8190b1b139c78913a1f892f (patch)
tree993079d75722225499e2d7185ac250e26d7d9ecc /ops/journaldriver/Cargo.toml
parentf817ad86f24ce4387878cd10c4746599cb9167c9 (diff)
refactor(journaldriver): Replace ureq with crimp r/3862
crimp is in TVL (//net/crimp), and it has fewer dependencies than
ureq (including - finally - no more old time or chrono).

Change-Id: I354f8f78b34a85abe3af671ffeffbe6a7fded5ee
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5318
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'ops/journaldriver/Cargo.toml')
-rw-r--r--ops/journaldriver/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/ops/journaldriver/Cargo.toml b/ops/journaldriver/Cargo.toml
index b5af8d015e..4c32b893f7 100644
--- a/ops/journaldriver/Cargo.toml
+++ b/ops/journaldriver/Cargo.toml
@@ -7,6 +7,7 @@ edition = "2021"
 
 [dependencies]
 anyhow = "1.0"
+crimp = "0.2"
 env_logger = "0.5"
 lazy_static = "1.0"
 log = "0.4"
@@ -16,7 +17,6 @@ serde_derive = "1.0"
 serde_json = "1.0"
 systemd = "0.3"
 time = { version = "0.3", features = [ "serde-well-known", "macros" ]}
-ureq = { version = "0.6.2", features = [ "json" ]}
 
 [build-dependencies]
 pkg-config = "0.3"