about summary refs log tree commit diff
path: root/nixos/configuration.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-02-23T19·32+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-02-23T19·32+0000
commit3f46ac65133721262380033cfa6820f03a90be6f (patch)
tree5a94c87de39a261cfadfa0963c3611dcaba12f51 /nixos/configuration.nix
parentf926b4d61ab9fbb2831c52594ed2e523842c1e24 (diff)
Change systemd unit type: oneshot -> simple
"oneshot", according to `man systemd.service`, "will consider the unit up after
the main process exits". Since I designed token-server to run continuously, it
will not intentionally exit; therefore, systemd awaits its exit, which never
comes. "simple", on the other hand, does what I want.
Diffstat (limited to 'nixos/configuration.nix')
-rw-r--r--nixos/configuration.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/configuration.nix b/nixos/configuration.nix
index f34e15f00495..a60164cb75bf 100644
--- a/nixos/configuration.nix
+++ b/nixos/configuration.nix
@@ -90,7 +90,7 @@ in {
 
     serviceConfig = {
       WorkingDirectory = "%h/briefcase/monzo_ynab";
-      Type = "oneshot";
+      Type = "simple";
     };
   };