about summary refs log tree commit diff
path: root/nix/nint/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2021-09-09T16·26+0200
committersterni <sternenseemann@systemli.org>2021-09-10T11·08+0000
commit318d10e60875ef69132651668a249de75730d2ba (patch)
treeaa3afe8c249edf6ab398657895afbfd271ef91b1 /nix/nint/default.nix
parent5d5fb4e6a1b3baee89d89f17ebc11bc19888c59a (diff)
chore(nint): move from //users/sterni to //nix r/2833
Since //web/bubblegum depends on nint, we need to move it to a non user
directory to conform with the policy established via cl/3434.
Note that this likely doesn't mean greater stability (which isn't
really implied in depot anyways), since I still would like to use a more
elaborate calling convention to allow for additional useful features.

Change-Id: I616f905d8df13e3363674aab69a797b0d39fdd79
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3506
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'nix/nint/default.nix')
-rw-r--r--nix/nint/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/nix/nint/default.nix b/nix/nint/default.nix
new file mode 100644
index 0000000000..5cf83d15d6
--- /dev/null
+++ b/nix/nint/default.nix
@@ -0,0 +1,14 @@
+{ depot, pkgs, ... }:
+
+let
+  inherit (depot.nix.writers)
+    rustSimpleBin
+    ;
+in
+
+  rustSimpleBin {
+    name = "nint";
+    dependencies = [
+      depot.third_party.rust-crates.serde_json
+    ];
+  } (builtins.readFile ./nint.rs)