about summary refs log tree commit diff
path: root/nix/getBins/tests.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2020-06-27T21·14+0200
committerProfpatsch <mail@profpatsch.de>2020-06-28T17·58+0000
commit98a990c6a60c56920c0748f459af06a3aed25242 (patch)
tree802c7e6a3b01718bec94c5f2cc1631387dfdb393 /nix/getBins/tests.nix
parent15335e7b3dad497dd45633d91db62015b67f08e3 (diff)
feat(nix/getBins): add getBins r/1107
This is a simple-stupid “unix import system” for nix, for referencing
binaries in `/bin/` by their name and lifting them to a Nix attrset.

Allows for simple aliasing of executable names.

Change-Id: Ifa23cb377201c3b08050c5026e9751e736afaf56
Reviewed-on: https://cl.tvl.fyi/c/depot/+/664
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'nix/getBins/tests.nix')
-rw-r--r--nix/getBins/tests.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/nix/getBins/tests.nix b/nix/getBins/tests.nix
new file mode 100644
index 0000000000..ff81deb5f1
--- /dev/null
+++ b/nix/getBins/tests.nix
@@ -0,0 +1,40 @@
+{ writeScriptBin, assertEq, it, runTestsuite, getBins }:
+
+let
+  drv = writeScriptBin "hello" "it’s me";
+  drv2 = writeScriptBin "goodbye" "tschau";
+
+  bins = getBins drv [
+            "hello"
+            { use = "hello"; as = "also-hello"; }
+          ]
+      // getBins drv2 [ "goodbye" ]
+      ;
+
+  simple = it "path is equal to the executable name" [
+    (assertEq "path"
+      bins.hello
+      "${drv}/bin/hello")
+    (assertEq "content"
+      (builtins.readFile bins.hello)
+      "it’s me")
+  ];
+
+  useAs = it "use/as can be used to rename attributes" [
+    (assertEq "path"
+      bins.also-hello
+      "${drv}/bin/hello")
+  ];
+
+  secondDrv = it "by merging attrsets you can build up bins" [
+    (assertEq "path"
+      bins.goodbye
+      "${drv2}/bin/goodbye")
+  ];
+
+in
+  runTestsuite "getBins" [
+    simple
+    useAs
+    secondDrv
+  ]