about summary refs log tree commit diff
path: root/nix/buildGo/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@tvl.su>2023-10-29T10·24+0300
committerclbot <clbot@tvl.fyi>2023-10-30T16·33+0000
commit67fed3d76deae9eb62f0313812c56e93e595cb3a (patch)
tree6bb8398da01ce4829778f7f392025e27182be6c3 /nix/buildGo/default.nix
parentc37c9cc77037dc511ea7683ea8e80795e3b9188f (diff)
chore(tools/depotfmt): use Go version from buildGo r/6915
This is required because Go 1.18 is actually being deleted. I've
applied the formatting breakage that it introduces (such as breaking
comment formatting), because I can't be bothered to try and work
around broken Go stuff.

Change-Id: Ica7cee0d01228845d6a766079fef36df99a3da96
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9832
Autosubmit: tazjin <tazjin@tvl.su>
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'nix/buildGo/default.nix')
-rw-r--r--nix/buildGo/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nix/buildGo/default.nix b/nix/buildGo/default.nix
index a7b1f6771e..83b9064bab 100644
--- a/nix/buildGo/default.nix
+++ b/nix/buildGo/default.nix
@@ -118,4 +118,7 @@ in
   program = makeOverridable program;
   package = makeOverridable package;
   external = makeOverridable external;
+
+  # re-expose the Go version used
+  inherit go;
 }