about summary refs log tree commit diff
path: root/home/modules/twitter.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-06-08T14·19-0400
committerGriffin Smith <root@gws.fyi>2020-06-08T14·19-0400
commit5477cc1b2a71b11810e4dee195dea3f74a9942d3 (patch)
tree14b2837e6b098d21bae1f9601bcc91f33b50d24f /home/modules/twitter.nix
parent77f3860a651ee7f35c8e65747c0c45fb001cfb0b (diff)
some twitter functions
Diffstat (limited to 'home/modules/twitter.nix')
-rw-r--r--home/modules/twitter.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/home/modules/twitter.nix b/home/modules/twitter.nix
index 9a6dc969b8..3cb2e90adc 100644
--- a/home/modules/twitter.nix
+++ b/home/modules/twitter.nix
@@ -9,7 +9,15 @@
     TWITTER_WHOAMI = "glittershark1";
   };
 
-  programs.zsh.shellAliases = {
-    "mytl" = "t tl $TWITTER_WHOAMI";
+  programs.zsh = {
+    shellAliases = {
+      "mytl" = "t tl $TWITTER_WHOAMI";
+    };
+
+    functions = {
+      favelast = "t fave $(t tl -l $1 | head -n1 | cut -d' ' -f1)";
+      rtlast = "t rt $(t tl -l $1 | head -n1 | cut -d' ' -f1)";
+      tthread = "t reply $(t tl -l $TWITTER_WHOAMI | head -n1 | cut -d' ' -f1) $@";
+    };
   };
 }