about summary refs log tree commit diff
path: root/home/modules/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-07T14·58-0400
committerGriffin Smith <root@gws.fyi>2020-05-07T14·58-0400
commit9ab4a9b2e4006fcee396bd21cc9debfd374c902c (patch)
tree01e6f58262a499889ff1bf68cdd6d632007929df /home/modules/shell.nix
parent5d5ec0f7a170c960ce729e4a61313d98852158ce (diff)
some new aliases and shell config
Diffstat (limited to 'home/modules/shell.nix')
-rw-r--r--home/modules/shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/home/modules/shell.nix b/home/modules/shell.nix
index 9378490bb6..be084793f3 100644
--- a/home/modules/shell.nix
+++ b/home/modules/shell.nix
@@ -14,6 +14,7 @@ let
     # Nix
     ns = "nix-shell";
     nb = "nix build -f .";
+    nc = "nix copy --to https://nix.urbinternal.com";
     "nc." = "nix copy -f . --to https://nix.urbinternal.com";
 
     # Docker and friends
@@ -71,6 +72,7 @@ let
     "grim" = "git fetch && git rebase -i origin/master";
     "grc" = "git rebase --continue";
     "gcan" = "git commit --amend --no-edit";
+    "grl" = "git reflog";
 
     # Aliases from old config
     stck = "dirs -v";
@@ -131,6 +133,11 @@ in {
 
     inherit shellAliases;
 
+    history = rec {
+      save = 100000;
+      size = save;
+    };
+
     oh-my-zsh = {
       enable = true;