about summary refs log tree commit diff
path: root/home/modules/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·44-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·44-0400
commit82c0404c4fccc163fab4efa11f0fb8986de8858d (patch)
tree89911ccd4fe73a421e9063ed083c9c53dd67ba79 /home/modules/shell.nix
parent9036dc7c32739d302cdd6fe51fe2d01418a99c9d (diff)
Make Tramp work
per
https://wxchen.wordpress.com/2012/05/20/getting-tramp-in-emacs-to-work-with-zsh-as-default-shell/,
make the PS1 etc. properly work with Tramp so I can edit stuff over
ssh (it's working quite well)
Diffstat (limited to 'home/modules/shell.nix')
-rw-r--r--home/modules/shell.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/home/modules/shell.nix b/home/modules/shell.nix
index be084793f3..69672473af 100644
--- a/home/modules/shell.nix
+++ b/home/modules/shell.nix
@@ -207,7 +207,14 @@ in {
       autoload -U promptinit; promptinit
       prompt pure
 
-      [[ ! $IN_NIX_SHELL ]] && alsi -l
+      if [[ "$TERM" == "dumb" ]]; then
+        unsetopt zle
+        unsetopt prompt_cr
+        unsetopt prompt_subst
+        unfunction precmd
+        unfunction preexec
+        export PS1='$ '
+      fi
     '';
   };