about summary refs log tree commit diff
path: root/home/modules/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-29T16·47-0400
committerGriffin Smith <root@gws.fyi>2020-03-29T16·47-0400
commit678c6b05d32dfc0ff470b886804f4f59a0abd7e6 (patch)
tree2a10212006d1ad8a6539de7dba440b760cdf0c0a /home/modules/shell.nix
parent28ccec970435f9acfdecfae95848947c8b751e09 (diff)
Begin breaking environment variables into shell.nix
Diffstat (limited to 'home/modules/shell.nix')
-rw-r--r--home/modules/shell.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/home/modules/shell.nix b/home/modules/shell.nix
index 51dc0e3670..e37272cd4e 100644
--- a/home/modules/shell.nix
+++ b/home/modules/shell.nix
@@ -5,6 +5,13 @@
     autojump
   ];
 
+  home.sessionVariables = {
+    EDITOR = "vim";
+    LS_COLORS = "no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.ogg=01;35:*.mp3=01;35:*.wav=01;35:";
+    TWITTER_WHOAMI = "glittershark1";
+    BROWSER = "firefox";
+  };
+
   programs.zsh = {
     enable = true;
     enableAutosuggestions = true;