about summary refs log tree commit diff
path: root/home/modules/i3.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-04-04T15·45-0400
committerGriffin Smith <root@gws.fyi>2020-04-04T15·45-0400
commita8e42d6e6d811ca31862606263f5818c95b0ab18 (patch)
tree06996f1f6118afd73e993e98f68a25a7e11f3c35 /home/modules/i3.nix
parent4da947bf9102d719b3d3de5523c4eb398a57558d (diff)
binding for peek
Diffstat (limited to 'home/modules/i3.nix')
-rw-r--r--home/modules/i3.nix15
1 files changed, 13 insertions, 2 deletions
diff --git a/home/modules/i3.nix b/home/modules/i3.nix
index 1c02939ecb..b4ffd202e0 100644
--- a/home/modules/i3.nix
+++ b/home/modules/i3.nix
@@ -36,13 +36,18 @@ in {
     let decorationFont = "MesloLGSDZ ${toString config.system.machine.i3FontSize}"; in
     {
       home.packages = with pkgs; [
-        maim
         rofi
         rofi-pass
-        i3status
         python38Packages.py3status
         i3lock
         dconf # for gtk
+
+        # Screenshots
+        maim
+
+        # GIFs
+        picom
+        peek
       ];
 
       xsession.scriptPath = ".hm-xsession";
@@ -82,6 +87,12 @@ in {
             # Screenshots
             "${mod}+q" = "exec \"maim | xclip -selection clipboard -t image/png\"";
             "${mod}+Shift+q" = "exec \"maim -s | xclip -selection clipboard -t image/png\"";
+            "${mod}+Ctrl+q" = "exec ${pkgs.writeShellScript "peek.sh" ''
+            picom &
+            picom_pid=$!
+            peek || true
+            kill -SIGINT $picom_pid
+            ''}";
 
             # Launching applications
             "${mod}+u" =