about summary refs log tree commit diff
path: root/home/modules/games.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
commit9036dc7c32739d302cdd6fe51fe2d01418a99c9d (patch)
tree2f67188616193c8b9b3de011d0bc546aca68a5ee /home/modules/games.nix
parent86b5f58ca51bfb91de4cd29e66b781d5e035db7a (diff)
Beginnings of config for Darwin machines
Split out a platforms/ directory with a linux.nix and darwin.nix, and
starting splitting things out between the two
Diffstat (limited to 'home/modules/games.nix')
-rw-r--r--home/modules/games.nix22
1 files changed, 13 insertions, 9 deletions
diff --git a/home/modules/games.nix b/home/modules/games.nix
index c68342ba6b..a9adf9c910 100644
--- a/home/modules/games.nix
+++ b/home/modules/games.nix
@@ -1,6 +1,7 @@
 { config, lib, pkgs, ... }:
 
 with pkgs;
+with lib;
 
 let
 
@@ -42,13 +43,16 @@ let
     chmod +x $out/bin/dwarf-fortress
   '';
 
-in {
-  imports = [
-    ./obs.nix
-  ];
+in mkMerge [
+  {
+    home.packages = [
+      crawl
+    ];
+  }
+  (mkIf stdenv.isLinux {
+    home.packages = [
+      df
+    ];
+  })
+]
 
-  home.packages = [
-    crawl
-    df
-  ];
-}