about summary refs log tree commit diff
path: root/home/modules/common.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
commit9036dc7c32739d302cdd6fe51fe2d01418a99c9d (patch)
tree2f67188616193c8b9b3de011d0bc546aca68a5ee /home/modules/common.nix
parent86b5f58ca51bfb91de4cd29e66b781d5e035db7a (diff)
Beginnings of config for Darwin machines
Split out a platforms/ directory with a linux.nix and darwin.nix, and
starting splitting things out between the two
Diffstat (limited to 'home/modules/common.nix')
-rw-r--r--home/modules/common.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/home/modules/common.nix b/home/modules/common.nix
new file mode 100644
index 0000000000..ad712a335b
--- /dev/null
+++ b/home/modules/common.nix
@@ -0,0 +1,38 @@
+{ config, lib, pkgs, ... }:
+
+{
+  imports = [
+    ../modules/shell.nix
+    ../modules/development.nix
+    ../modules/emacs.nix
+    ../modules/vim.nix
+    ../modules/tarsnap.nix
+  ];
+
+  nixpkgs.config.allowUnfree = true;
+  programs.password-store.enable = true;
+
+  impure.clonedRepos.passwordStore = {
+    github = "glittershark/pass";
+    path = ".local/share/password-store";
+  };
+
+  home.packages = with pkgs; [
+    htop
+    killall
+    bind
+    zip unzip
+    tree
+    ncat
+
+    gnupg
+    keybase
+    openssl
+
+    # Nix things
+    nixfmt
+    nix-prefetch-github
+    nix-review
+    cachix
+  ];
+}