about summary refs log tree commit diff
path: root/home/modules/common.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T15·27-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T15·28-0400
commit0275aaec03149b641ef2d6516cad20bddcce6bb5 (patch)
tree98012a815b9bdd3c5c30141d065ef2ed1690f863 /home/modules/common.nix
parent9b2dd5c20fec6ca76adb470374ccea0f7c944233 (diff)
some adjustments to per-platform config
Diffstat (limited to 'home/modules/common.nix')
-rw-r--r--home/modules/common.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/home/modules/common.nix b/home/modules/common.nix
index ad712a335b..72107a459f 100644
--- a/home/modules/common.nix
+++ b/home/modules/common.nix
@@ -1,5 +1,7 @@
 { config, lib, pkgs, ... }:
 
+# Everything in here needs to work on linux or darwin
+
 {
   imports = [
     ../modules/shell.nix
@@ -7,17 +9,23 @@
     ../modules/emacs.nix
     ../modules/vim.nix
     ../modules/tarsnap.nix
+    ../modules/lib/cloneRepo.nix
   ];
 
   nixpkgs.config.allowUnfree = true;
+
   programs.password-store.enable = true;
 
-  impure.clonedRepos.passwordStore = {
+  grfn.impure.clonedRepos.passwordStore = {
     github = "glittershark/pass";
     path = ".local/share/password-store";
   };
 
+  urbint.projectPath = "code/urb";
+
   home.packages = with pkgs; [
+    # System utilities
+    bat
     htop
     killall
     bind
@@ -25,6 +33,7 @@
     tree
     ncat
 
+    # Security
     gnupg
     keybase
     openssl