about summary refs log tree commit diff
path: root/home/modules/alsi.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-28T03·32-0400
committerGriffin Smith <root@gws.fyi>2020-03-28T15·47-0400
commit28ccec970435f9acfdecfae95848947c8b751e09 (patch)
tree4a55bdaab006c46cd5ad86d407d7d80fab8ed57f /home/modules/alsi.nix
Initial commit
It begins...
Diffstat (limited to 'home/modules/alsi.nix')
-rw-r--r--home/modules/alsi.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/home/modules/alsi.nix b/home/modules/alsi.nix
new file mode 100644
index 0000000000..cb9802e2ce
--- /dev/null
+++ b/home/modules/alsi.nix
@@ -0,0 +1,41 @@
+{ config, lib, pkgs, ... }:
+let alsi = pkgs.callPackage ../../pkgs/alsi {};
+in
+{
+  home.packages = [ alsi ];
+
+  home.file.".config/alsi/alsi.logo" = {
+    source = ./nixos-logo.txt;
+    force = true;
+  };
+
+  home.file.".config/alsi/alsi.conf" = {
+    text = ''
+    #!${pkgs.perl}/bin/perl
+
+    scalar {
+      ALSI_VERSION         => "0.4.8",
+      COLORS_FILE          => "/home/grfn/.config/alsi/alsi.colors",
+      DE_FILE              => "/home/grfn/.config/alsi/alsi.de",
+      DEFAULT_COLOR_BOLD   => "blue",
+      DEFAULT_COLOR_NORMAL => "blue",
+      DF_COMMAND           => "df -Th -x sys -x tmpfs -x devtmpfs &>/dev/stdout",
+      GTK2_RC_FILE         => "/home/grfn/.gtkrc-2.0",
+      GTK3_RC_FILE         => "/home/grfn/.config/gtk-3.0/settings.ini",
+      LOGO_FILE            => "/home/grfn/.config/alsi/alsi.logo",
+      OUTPUT_FILE          => "/home/grfn/.config/alsi/alsi.output",
+      # PACKAGES_PATH        => "/var/lib/pacman/local/",
+      PS_COMMAND           => "ps -A",
+      USAGE_COLORS         => 0,
+      USAGE_COLORS_BOLD    => 0,
+      USAGE_PRECENT_GREEN  => 50,
+      USAGE_PRECENT_RED    => 100,
+      USAGE_PRECENT_YELLOW => 85,
+      USE_LOGO_FROM_FILE   => 1,
+      USE_VALUES_COLOR     => 0,
+      WM_FILE              => "/home/grfn/.config/alsi/alsi.wm",
+    }
+    '';
+    force = true;
+  };
+}