about summary refs log tree commit diff
path: root/home/modules/alacritty.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-03-31T21·10-0400
committerGriffin Smith <root@gws.fyi>2020-03-31T21·10-0400
commit2de47035c93590c5ab3d4815e45391ae74c09444 (patch)
tree6f24cac9910f233539931eb9f250869c310918e2 /home/modules/alacritty.nix
parent58741dad6307672fe1f9618043e29e6ccc122041 (diff)
fix alacritty bright colors
needed to get vim color scheme working as expected
Diffstat (limited to 'home/modules/alacritty.nix')
-rw-r--r--home/modules/alacritty.nix25
1 files changed, 14 insertions, 11 deletions
diff --git a/home/modules/alacritty.nix b/home/modules/alacritty.nix
index ba26360fe9..34ccf47f18 100644
--- a/home/modules/alacritty.nix
+++ b/home/modules/alacritty.nix
@@ -8,6 +8,9 @@
     enable = true;
     settings = {
       font.size = 6;
+      font.normal.family = "Meslo LGSDZ Nerd Font";
+
+      draw_bold_text_with_bright_colors = false;
 
       colors = with import ../common/solarized.nix; rec {
         # Default colors
@@ -29,17 +32,17 @@
         };
 
         # Bright colors
-        bright = normal;
-        # bright = {
-        #   black = base03;
-        #   red = orange;
-        #   green = base01;
-        #   yellow = base00;
-        #   blue = base0;
-        #   magenta = violet;
-        #   cyan = base1;
-        #   white = base3;
-        # };
+        # bright = normal;
+        bright = {
+          black = base03;
+          red = orange;
+          green = base01;
+          yellow = base00;
+          blue = base0;
+          magenta = violet;
+          cyan = base1;
+          white = base3;
+        };
       };
     };
   };