about summary refs log tree commit diff
path: root/home/home.nix
diff options
context:
space:
mode:
authorGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
committerGriffin Smith <root@gws.fyi>2020-05-26T14·43-0400
commit9036dc7c32739d302cdd6fe51fe2d01418a99c9d (patch)
tree2f67188616193c8b9b3de011d0bc546aca68a5ee /home/home.nix
parent86b5f58ca51bfb91de4cd29e66b781d5e035db7a (diff)
Beginnings of config for Darwin machines
Split out a platforms/ directory with a linux.nix and darwin.nix, and
starting splitting things out between the two
Diffstat (limited to 'home/home.nix')
-rw-r--r--home/home.nix107
1 files changed, 1 insertions, 106 deletions
diff --git a/home/home.nix b/home/home.nix
index 42debbfc34..39045c147d 100644
--- a/home/home.nix
+++ b/home/home.nix
@@ -1,28 +1,12 @@
 { config, pkgs, ... }:
 
-let machine = ./machines/chupacabra.nix; in
 {
   imports = [
-    ./modules/alacritty.nix
-    ./modules/alsi.nix
-    ./modules/development.nix
-    ./modules/emacs.nix
-    ./modules/email.nix
-    ./modules/firefox.nix
-    ./modules/games.nix
-    ./modules/i3.nix
-    ./modules/shell.nix
-    ./modules/tarsnap.nix
-    ./modules/vim.nix
-
-    ~/code/urb/urbos/home
-
-    machine
+    (throw "Pick a machine from ./machines")
   ];
 
   # Let Home Manager install and manage itself.
   programs.home-manager.enable = true;
-  xsession.enable = true;
 
   # This value determines the Home Manager release that your
   # configuration is compatible with. This helps avoid breakage
@@ -33,93 +17,4 @@ let machine = ./machines/chupacabra.nix; in
   # the Home Manager release notes for a list of state version
   # changes in each release.
   home.stateVersion = "19.09";
-
-  # for when hacking
-  programs.home-manager.path = "/home/grfn/code/home-manager";
-
-  home.packages = with pkgs; [
-    (import (fetchTarball "https://github.com/ashkitten/nixpkgs/archive/init-glimpse.tar.gz") {}).glimpse
-
-    # Desktop stuff
-    arandr
-    firefox
-    feh
-    chromium
-    xclip
-    xorg.xev
-    picom
-    peek
-    signal-desktop
-    apvlv # pdf viewer
-    vlc
-    irssi
-    gnutls
-    pandoc
-    barrier
-
-    # System utilities
-    htop
-    powertop
-    usbutils
-    pciutils
-    killall
-    gdmap
-    bind
-    lsof
-    zip
-    tree
-    ncat
-    unzip
-
-    # Security
-    gnupg
-    keybase
-    openssl
-
-    # Spotify...etc
-    spotify
-    playerctl
-
-    # Nix things
-    nixfmt
-    nix-prefetch-github
-    nix-review
-    cachix
-  ];
-
-  nixpkgs.config.allowUnfree = true;
-
-  programs.password-store.enable = true;
-
-  services.redshift = {
-    enable = true;
-    provider = "geoclue2";
-  };
-
-  services.pasystray.enable = true;
-
-  impure.clonedRepos.passwordStore = {
-    github = "glittershark/pass";
-    path = ".local/share/password-store";
-  };
-
-  urbint.projectPath = "code/urb";
-
-  services.gpg-agent = {
-    enable = true;
-  };
-
-  gtk = {
-    enable = true;
-    gtk3.bookmarks = [
-      "file:///home/grfn/code"
-    ];
-  };
-
-  programs.tarsnap = {
-    enable = true;
-    keyfile = "/home/grfn/.private/tarsnap.key";
-    printStats = true;
-    humanizeNumbers = true;
-  };
 }