about summary refs log tree commit diff
path: root/fun/tvldb/Cargo.toml
diff options
context:
space:
mode:
authoreta <eta@theta.eu.org>2020-06-15T20·03+0100
committereta <eta@theta.eu.org>2020-06-16T13·30+0000
commitc3abbb5e2daeec07d03f1addd4a6c905af7a02ac (patch)
tree416ba1be719dd3ebbd15ee41b6f8a2c1b944bd43 /fun/tvldb/Cargo.toml
parent4c22cf316933613215e83f70a6bb2c556d42e02c (diff)
feat(tvldb): Import the tvldb/paroxysm source, add a Nix derivation r/993
- This imports the tvldb (actually a thing called 'paroxysm') code
  from https://git.theta.eu.org/eta/paroxysm into the monorepo.
- Additionally, I did a nix thing, yay! \o/
  (well, with tazjin's help)
- 3p/default.nix needed modifying to whitelist pgsql.

Change-Id: Icdf13ca221650dde376f632bd2dd8a087af451bf
Reviewed-on: https://cl.tvl.fyi/c/depot/+/389
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'fun/tvldb/Cargo.toml')
-rw-r--r--fun/tvldb/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/fun/tvldb/Cargo.toml b/fun/tvldb/Cargo.toml
new file mode 100644
index 0000000000..91a68d4f06
--- /dev/null
+++ b/fun/tvldb/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+authors = ["eeeeeta <eta@theta.eu.org>"]
+edition = "2018"
+name = "paroxysm"
+version = "0.1.0"
+
+[dependencies]
+chrono = "0.4.6"
+config = "0.9.1"
+env_logger = "0.6.0"
+failure = "0.1.3"
+irc = "0.13.6"
+lazy_static = "1.2.0"
+log = "0.4.6"
+rand = "0.7.3"
+regex = "1.1.0"
+serde = "1.0.81"
+serde_derive = "1.0.81"
+
+[dependencies.diesel]
+features = ["postgres", "chrono", "r2d2"]
+version = "1.3.3"