about summary refs log tree commit diff
path: root/fun/paroxysm/default.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2024-03-11T16·34+0100
committerclbot <clbot@tvl.fyi>2024-03-11T16·52+0000
commit4ec596c8f9cfb774b81685e8f1a56cc1b93bb950 (patch)
tree542ee9941f32695fe47fc9d684c1ce8ea3e7c65f /fun/paroxysm/default.nix
parentb40c4500a3d982a72f9fca62bc61c8bf74606b16 (diff)
chore(fun/paroxysm): update deps and build against in tree crimp r/7682
To achieve this we switch to crate2nix which also requires us to
run `cargo update` before the switch.

Change-Id: I8c19a51f90f344e80064e70a4a2799d1c6db62ec
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11134
Tested-by: BuildkiteCI
Autosubmit: sterni <sternenseemann@systemli.org>
Reviewed-by: tazjin <tazjin@tvl.su>
Diffstat (limited to 'fun/paroxysm/default.nix')
-rw-r--r--fun/paroxysm/default.nix20
1 files changed, 8 insertions, 12 deletions
diff --git a/fun/paroxysm/default.nix b/fun/paroxysm/default.nix
index 1aeaeb9912..54f59dc476 100644
--- a/fun/paroxysm/default.nix
+++ b/fun/paroxysm/default.nix
@@ -1,14 +1,10 @@
-{ depot, pkgs, ... }:
+{ pkgs, ... }:
 
-depot.third_party.naersk.buildPackage {
-  name = "paroxysm";
-  version = "0.0.2";
-  src = ./.;
+let
+  cargoNix = import ./Cargo.nix {
+    inherit pkgs;
+    nixpkgs = pkgs.path;
+  };
+in
 
-  buildInputs = with pkgs; [
-    openssl
-    pkg-config
-    postgresql.lib
-    curl
-  ];
-}
+cargoNix.rootCrate.build